[CentOS] Problem with yum after upgrading from 4.5 to 5.0

Thomas Dukes tdukes at sc.rr.com
Wed Jun 20 12:07:40 UTC 2007


-----Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
Of Jim Perrin
Sent: Wednesday, June 20, 2007 7:28 AM
To: CentOS mailing list
Subject: Re: [CentOS] Problem with yum after upgrading from 4.5 to 5.0

On 6/20/07, Thomas Dukes <tdukes at sc.rr.com> wrote:
> Hello,
> Have pretty much figured out I can't use plugins since upgrading.  If 
> I use yum update --noplugins to get the updates for 5.0, I get:

That's an UGLY upgrade because of python-elementree conflicts and a few
other pieces. I really would not do such a thing unless there were
absolutely no other way.

> Warning: rpmts_HdrFromFdno: Header V# DSA signature: NOKEY, key ID 
> e8562897
> Public key for samba-common-3.0.23c-2.el5.2.0.2.i386.rpm is not 
> installed
> I looked back through the archives and think I may need a 
> rpmforge-release key but have not been able to find it.  Is this right?

No, that's a standard distro package. It's complaining that you don't have
the key for centos5 installed, not the rpmforge key. For c5, the key should
be in /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
You can import this with rpm --import
/etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5, but I don't think it'll solve all
your issues.

Thanks, that worked!

Other problems????  What am I in for???


During times of universal deceit, telling the truth becomes a revolutionary
George Orwell
CentOS mailing list
CentOS at centos.org

More information about the CentOS mailing list