[CentOS] upgrade aspell , glibc and glibc-common

Centos centos at unixplanet.biz
Wed Jun 27 16:30:08 UTC 2007


Is there any glibc-2.6 rpm available for centos 4.4.
I was trying to upgrade aspell to .6 which I got following error :
error: Failed dependencies:
libc.so.6(GLIBC_2.4) is needed by aspell-0.60.3-7.1.i386
rtld(GNU_HASH) is needed by aspell-0.60.3-7.1.i386

so I think i need to upgrade glibc and glibc-common to be able to 
upgrade aspell,
and I get dependency error while I am upgrading glibc or glibc-common.
glibc and glibc-common seems to be in loop dependency wise.

error: Failed dependencies:
glibc < 2.5 conflicts with glibc-common-2.5-12.i386
glibc-common = 2.3.4-2.36 is needed by (installed) glibc-2.3.4-2.36.i686

error: Failed dependencies:
glibc-common = 2.5-12 is needed by glibc-2.5-12.i386
glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.36.i386
glibc = 2.3.4-2.36 is needed by (installed) glibc-headers-2.3.4-2.36.i386
glibc = 2.3.4-2.36 is needed by (installed) glibc-devel-2.3.4-2.36.i386

More information about the CentOS mailing list