[CentOS] missing Nagios dependencies: how to fix on yum?

RR scubacuda at gmail.com
Wed Jun 27 21:59:01 UTC 2007

On CentOS, I am trying to "yum install nagios" (after adding the rpmforge
repository), but every time I run it, I get this message, and am not sure
quite what to do.

[root at nagios-server ~]# yum install nagios
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nagios.i386 0:2.9-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: rtld(GNU_HASH) for package: nagios
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: nagios
--> Finished Dependency Resolution
Error: Missing Dependency: rtld(GNU_HASH) is needed by package nagios
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package nagios

I ran "yum install httpd gcc glibc glibc-common gd gd-devel" (just like the
Nagios HOWTO) thinking that it would resolve the dependencies, but I still
get these errors.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20070627/c87126ed/attachment.htm

More information about the CentOS mailing list