[CentOS] missing Nagios dependencies: how to fix on yum?

Jim Perrin jperrin at gmail.com
Thu Jun 28 21:56:05 UTC 2007

On 6/28/07, RR <scubacuda at gmail.com> wrote:

> I then followed the CentOS 4 instructions at
> http://wiki.centos.org/Repositories/RPMForge but "yum
> install nagios" gives me the following error.
> [root at nagios-server tmp]# yum install nagios
> Loading "protectbase" plugin
> Setting up Install Process
> Setting up repositories
> Reading repository metadata in from local files
> 81 packages excluded due to repository protections
> Parsing package install arguments
> Resolving Dependencies
> --> Populating transaction set with selected packages. Please wait.
> ---> Package nagios.i386 0:2.9-1.el5.rf set to be updated

See how it still has the .el5.rf in there? Yum is still pulling in the
el5 packages. Double check your /etc/yum.repos.d/rpmforge.repo file to
see if it spells out version 5. Also you will likely have to clear the
yum cache. 'yum clean all' should do the trick.

During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell

More information about the CentOS mailing list