[CentOS] Dependency problem - libijs.so

Jim Perrin jperrin at gmail.com
Tue Mar 13 02:16:53 UTC 2007

On 3/12/07, Robert Moskowitz <rgm at htt-consult.com> wrote:
> Here is what I am seeing:
> --> Populating transaction set with selected packages. Please wait.
> ---> Package evolution-data-server.i386 0:1.0.2-13.el4 set to be updated
> ---> Package php.i386 0:4.3.11-2.8 set to be updated

Well that's not right. CentOS doesn't ship this version.

> ---> Package rsync.i386 0:2.6.8-1.el4.rf set to be updated

This one isn't ours either, though rpmforge is okay.

> ---> Package ghostscript.i386 0:8.15.1-7 set to be updated

This is really the problem here, as this is the rpm which SHOULD
provide this file, however this isn't a centos package. In fact, I'm
beginning to suspect your problem isn't centos related at all, but
more likely a centos spin-off like trixbox or something similar. You
should consider asking them to QA what they release.

> Error: Missing Dependency: libijs.so is needed by package gimp-print

If I had to guess, I'd say it's a trixbox rebuild with a much newer
ghostscript, but the same old gimp-print which hasn't been rebuilt
against the newer packages which provide its deps.

Since we're not the vendor here, I'd recommend talking to whoever you
got your software from.

During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell

More information about the CentOS mailing list