[CentOS] snmp on centos 3.x x86_64

Les Mikesell lesmikesell at gmail.com
Fri Mar 23 18:24:43 UTC 2007

Matt Hyclak wrote:
> On Wed, Mar 21, 2007 at 10:41:23AM -0500, Les Mikesell enlightened us:
>> I'm trying to use opennms to collect data from some CentOS3.x x86_64
>> boxes but I am getting an  error  "Integer too large: cannot decode"
>> that  http://bugzilla.opennms.org/cgi-bin/bugzilla/show_bug.cgi?id=1316
>> says is a bug in net-snmp  that was fixed in a later version.   However,
>> when I try to build the 5.4.1 src.rpm from sourceforge I get
>> "/usr/lib/libpopt.so: could not read symbols: Invalid operation"
>> although it builds OK on a 32 bit system.  Has anyone worked around this 
>> problem?  Or is it really a bug in opennms?
> In a time long ago and a land far far away, I tried building a 64-bit
> package with a 32-bit popt installed on it (I think it was galeon, but I
> could be wrong). As long as popt.i386 was installed, the build failed with
> the same error. Removing it (leaving only popt.x86_64) allowed the build to
> complete. 
> If you're going to build 64-bit packages, you'll want a system with as few
> i386 packages as possible. I recall an e-mail earlier this month from Johnny
> that listed only 3.

Thanks - I had to use --nodeps' to get rid of popt.i386 but after that 
the 5.4.1 rpm rebuild worked, and it is working now with opennms.

  Les Mikesell
    lesmikesell at gmail.com

More information about the CentOS mailing list