[CentOS] SMP on a HP DL-320 G2

Thu Mar 1 03:05:14 UTC 2007
Jay Leafey <jay.leafey at mindless.com>

fredex wrote:
> Hi gang!
> At work I have a DL320 G2 machine I use as my desktop (I know, weird!...).
> Back when I ran RHEL WS 2.1 on it, it always ran a SMP kernel because it
> has a HypterThread capable processor.
> When I installed (fresh from scratch) Centos 4.4 on it a while back, though,
> Centos installed only the UP kernel.
> I've looked in the BIOS for settings to enable/disable HT support and
> I don't see anything.
> I've force-installed the SMP kernel and when I boot it it doesn't seem
> to think there's anything thre but a normal UP CPU.
> Should it not show two CPUs in top, and in suitable places in /proc like
> the earlier OS did? (at least when running a SMP kernel)
> Ideas welcome.
> Thanks!

The DL-320 G2's I've got (6 at last count) running CentOS/RHEL 3 and 4 all show up in /proc/cpuinfo as single-core with no 
hyperthreading.  Here's the example output from one of them:

[root at directory1 root]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.66GHz
stepping        : 9
cpu MHz         : 2666.038
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 5321.52

[root at directory1 root]#

I was a bit disappointed when we first got them because they weren't HT-capable, but they've worked very well for our purposes (DNS, 
DHCP, LDAP, etc.).
Jay Leafey - Memphis, TN
jay.leafey at mindless.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5177 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20070228/4b0157cd/attachment-0005.bin>