[CentOS] Install and Run mysql 4.x

Wed Mar 21 20:59:21 UTC 2007
Fabian Arrotin <fabian.arrotin at arrfab.net>

On Wed, 2007-03-21 at 13:00 -0700, Al Sparks wrote:
> You know, I suppose I could simply install the tarball, I've
> successfully installed mysql in the past that way.  However, I thought
> I'd use yum, install the redhat/CentOS way, and I am amazed how hard
> it is to get this thing working.  I admit to not having become all
> that familiar with mysql.
> Anyway, when I run 
>     # mysql_install_db --user=mysql
> I get a bunch of errors:
>     070321 11:50:43 [ERROR] /usr/libexec/mysqld: Can't find file: 
>     './mysql/help_topic.frm' (errno: 13)
> So I find out where the file is, and 
>    cd /var/lib/mysql
> and to confirm I do a
>    ls ./mysql/help_relation.frm
> I run 
>    # mysql_install_db --user=mysql
> Same error.  I'll be glad for some help, but a secondary point I'd
> like to make is, what's the point in having packages if a lot of this
> stuff isn't already taken care of?  Obviously the yum package manager
> puts the mysql distro in different places than the mysql tarball does
> by default.  But shouldn't the package's config files take all that
> into account?
> Why is this so hard?

You don't have to initialize mysql db : it will be done automagically
when you'll start the mysqld service for the first time (service mysqld
start) ...
Have a look in the mysqld init script (that rpm/yum provides you so
gently) , especially in the start() function ...


Fabian Arrotin <fabian.arrotin at arrfab.net>
Solution ? 
echo '16i[q]sa[ln0=aln100%Pln100/snlbx]sbA0D4D465452snlbxq' | dc