[CentOS] Help with fdformat

Sat Mar 31 00:42:33 UTC 2007
fredex <fredex at fcshome.stoneham.ma.us>

On Fri, Mar 30, 2007 at 03:40:15PM -0400, Robert Moskowitz wrote:
> At: http://www.serverelements.com/naslite.php
> the following command is supplied near the bottom:
> **fdformat /dev/fd0u1722
> **
> I have plugged in my USB floppy drive and have a /media/floppy
> I get no such file or directory with this command.  And what is this 
> with a 1722 formatted floppy.  What I do a man fdformat, 1722 is not 
> listed....

I just tried it on Centos-4.4 with a USB floppy drive. It actually goes
with my son's laptop, so I've never used it before.

Anyway, I plug it in, stick in a floppy (with stuff already on it) and
boom, it mounts and pops up an icon on the screen. Cool!

unfortunately, I can't get fdformat (or 'floppy', either) to format
a diskette in it.

When it's mounted I can see:

/dev/sda on /media/floppy type vfat (rw,nosuid,nodev,user=fredex)

so I umount it and try:

	fdformat /dev/sda

and I get:

# fdformat /dev/sda
Could not determine current format type: Invalid argument

Tried the "floppy" command, also to no avail.

The only thing I've unearthed that works for formatting is to use
mformat. mformat writes a blank filesystem onto the floppy, BUT THE 

I added this line to my /etc/mtools.conf config file:

	drive z: file="/dev/sda" exclusive mformat_only

and I could then run mformat (or other mtools) against the usb floppy
as if it were drive Z:

even though I don't routinely use this device, now that I've gotten into
it I'd be interested to know if anyone else knows (or figures out) how
to do a real low-level format on a USB floppy.


---- Fred Smith -- fredex at fcshome.stoneham.ma.us ------------------------ ----
                    Do you not know? Have you not heard? 
    The LORD is the everlasting God, the Creator of the ends of the earth. 
  He will not grow tired or weary, and his understanding no one can fathom.
----------------------------- Isaiah 40:28 (niv) -----------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20070330/e5a78b2f/attachment-0005.sig>