[CentOS] Problems with Server and Mail server

Mon May 7 15:39:43 UTC 2007
Dago Pacheco <informatica at makimet.cl>

I've have problem with my file and mail server.  I have a Centos 4 with 
file and mail server for  my office network, which is compose with Linux 
(xandros 4) and windows (2k) work stations.  The problem is that 
suddenly some linux machines can't access the the remote files on the 
server, but they can see the server in the file manager, but there is no 
files.  When I enter as root, there is no problem... I can access remote 
files and devices in the server or in other machines (shared folder, 
files or devices).  Windows machines can access anywhere (server and 
others work stations, linux and windwos); some linux machine can access 
anywhere too, but other can't access the server but can access shared 
I think it may be a access permition issue, but this happens from one 
day to another, and in at least 3 linux machines... so, where can i look 
for solution in my server?

Other thing is the mail server (outgoing) doesn't work, when i try to 
send a mail through the mail server (the same file server machine), it 
search for the outgoing server ( and can't establish 
connection.  A linux user friend told me to shutdown the machine and 
disconect the power cord for a minute and then restart the system.  It 
worked for a time, but then it start the same problem and can only be 
solved by shooting down the system, and that is a bad solution.  The 
mail server use to work fine, 24/7.

These 2 problems start when a electric crash burned out the router, and 
then when i replaced it  the start to  happen, but router configuration 
is fine and doesn't seem to have a problem.

Please help me to identify or solve the problem. Thanks everyone

Dago Pacheco
Encargado de Informática
Maestranza Makimet Ltda.