[CentOS] trying to run sshd daemon in kickstart environment

Mon May 21 17:54:16 UTC 2007
Guolin Cheng <guolin at alexa.com>


  I tried to make kickstart environment a little bit more charming by
firing up openssh daemon in the limited environment. I edited/checked a
bunch of files and almost succeeded but still not.

  I can reach the machine to run a command like 'ssh -x
<kickstartClient> <command>' and it does work for %pre and both chroot
and non-chroot %post sections, in fact, you can run a command on
kickstartClient through ssh connections without problems.  But it still
fails because I can not ssh into the kickstartClient to get a local
command shell. 

 In short, 'ssh -x <kickstartClient>' fails, 'ssh -x <kickstartClient>
<command>' works.

 Any one has succeeded in this topic? Life will be much happier if we
can freely turn on/off sshd daemon for Kickstart environment. Thanks.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20070521/85e8345b/attachment-0004.html>