[CentOS] rsync problems on windows - Solved

Thu May 3 14:20:31 UTC 2007
Ruslan Sivak <rsivak at istandfor.com>

Les Mikesell wrote:
> Ruslan Sivak wrote:
>> Les Mikesell wrote:
>>> Russ wrote:
>>>> I'm not running any firewalls AFAIK.  I disabled mcafee, but the 
>>>> error persists.  I even tried a different os (win 2003, no 
>>>> firewall, no antivirus) and I'm still getting the same problem.  
>>>> Any way to troubleshoot?  I tried wireshark, but I all I are are 
>>>> encrypted packets and a rst at the end from the client.
>>>> Also the error pops up intantrneously, no timeout.  It then hangs 
>>>> until I ctrl-c out of it. Ssh works fine btw.  I can use it and get 
>>>> a shell.
>>>> I looked at the rsync.c file, but couldn't locate that error text 
>>>> anywhere.  Is that an error from rsync or ssh?   Is there a way to 
>>>> tell it not to use ssh to eliminate it as a problem?
>>> I just downloaded a current cwrsync and was able to cd into its bin 
>>> directory and 'rsync -av . root at centos_box:/tmp/test' without any 
>>> problems.  Maybe you have a problem with paths or another copy of 
>>> the cygwin.dll somewhere.
>> I checked for any other versions of cygwin1.dll, and although there 
>> were a few, they weren't in the path.  I finally got process monitor 
>> and process explorer and saw that for some reason it was using 
>> hlcap.dll.  I guess HTTPLook caused yet another problem.  Thanks to 
>> everyone that helped.  Does anyone know of a program like httplook 
>> for windows that doesn't break everything?
> I'm not quite sure what it does (its home page seems to redirect to 
> something in Russian), but if you want generic network sniffer, try 
> wireshark: http://www.wireshark.org/.
I do have wireshark, but HTTPLook is better in that it captures only 
HTTP traffic, which is all I'm interested in.  It organizes it in a nice 
timeline of requests and responses and I can see exactly what went on 
for each request.