[CentOS] CentOS 5 and Broadcom wireless

Fri May 11 14:19:28 UTC 2007
David G. Miller <dave at davenjudy.org>

"Bart Schaefer" <barton.schaefer at gmail.com> wrote:

> Is wpa_supplicant installed?
> It is, and I tried enabling it as well, but it spews a bunch of errors
> at boot time and exits.  It's apparent I need to edit
> /etc/sysconfig/wpa_supplicant, but if I'm *not* using ndiswrapper I
> don't know what to use in the DRIVERS= assignment.  So that's
> chkconfig'd off again.


This actually worked better for me than DRIVERS=ndiswrapper when I use 
ndiswrapper.  I think it tells wpa_supplicant that the kernel driver 
supports the generic wireless extensions.  As an example, I can get 
WPA-PSK authentication to work with DRIVERS=wext but not with 
ndiswrapper even though I'm running ndiswrapper.

I also did some googling and it looks like quite a bit of bcm43xx work 
has gone into kernels after 2.6.18.  No idea if these changes have been 
back ported by upstream to the current 2.6.18 kernel.  I have some 
friends visiting now but I'm planning on giving bcm43xx a whirl again 
with the 2.6.21 kernel. 


Politics, n. Strife of interests masquerading as a contest of principles.
-- Ambrose Bierce