[CentOS] Reformatting a USB drive

Thu May 24 23:11:33 UTC 2007
Todd Cary <todd at aristesoftware.com>

Jim -

Thank you!  That is exactly what I needed.  I had to make one change 
though since I use rsync to copy the data to the USB drive: I could not 
use vfat.  Instead, I used ext3.  With vfat, I got errors when it tried 
to do a chmod (expected).

I do have another fs question though.  A couple of weeks ago I noticed 
that the USB icon was not on my desktop when I turned the drive on.  Not 
knowing any better, I ran my rsync with the following:

/usr/bin/rsync -av --exclude=".*" -e ssh /home/ /media/usbdisk/

And it went ahead and did it's thing *but* the drive was 
inoperable...dead.  Where did the data go?

And I noticed with the new drive, if I turn it off, rsync puts the data 
somewhere with

/usr/bin/rsync -av --exclude=".*" -e ssh /home/ /media/usbdisk1/

I need a FS 101 course!!


Jim Perrin wrote:
> On 5/24/07, Todd Cary <todd at aristesoftware.com> wrote:
>> I have a USB drive that has been formatted as NTFS.  Can I reformat it?
>> I have identified these properties about it
>> /dev/sda1
>> /media/Extrnl_Bkup
>> Not sure what to do next since the GUI will not mount a NTFS disk
>> (expected).
> There are kernel ntfs modules, but really, the most universally
> supported option is to format with vfat. This way it will work on
> windows, mac and linux systems, fully supported all the way around.
> There are some limitations to fat32, 4G file sizes and the like.
> The quick and easy way is mkfs.vfat /dev/sda1....tap fingers for a
> minute... then unplug/reinsert.

Ariste Software
2200 D Street Ext
Petaluma, CA 94952
(707) 773-4523