[CentOS] mdadm syntax

James Olin Oden james.oden at gmail.com
Fri Nov 2 21:14:52 UTC 2007

On 11/2/07, Tim Verhoeven <tim.verhoeven.be at gmail.com> wrote:
> On Nov 2, 2007 8:14 PM, Art Baldini <rootajb at gmail.com> wrote:
> > Hi All,
> >     I am trying to create an MD device.  I am using the command:
> > /sbin/mdadm --create --a /dev/md12 --level=1 --run --raid-devices=2
> > /dev/sda12 /dev/sdb12
> > to create the device, and to dynamically create the device file if needed.
> > What I want is the device file to be created as /dev/md12, but with the -a
> > flag it creates it as /dev/md<first unwsed minor number>.
> >
> > I have tried various options to the -a or --auto, but cannot seem to find
> > the correct syntax.  From the man page it says:
> >        -a, --auto{=no,yes,md,mdp,part,p}{NN}
> >               Instruct mdadm to create the device file if needed, and to
> > allocate an unused
> >               minor number.  "yes" or "md" causes a non-partitionable  array
> > to  be  used.
> >               "mdp", "part" or "p" causes a partitionable array (2.6 and
> > later) to be used.
> >               The argumentment can also come immediately after "-a".  e.g.
> > "-ap".
> >
> > Am I doing something wrong, or is there no way to get mdadm to automatically
> > create a specific device file.
> I've done it like this :
> mdadm --create /dev/md12 --auto=yes --level=1 --run --raid-devices=2 /dev/...
The only difference is that he is doing -a rather than --auto=yes.  I
get the same result as Art is getting when I do it your way.   You can
still access it as /dev/md12, but it shows up in /proc/mdstat as
/dev/md0 (which is, well, weird).


More information about the CentOS mailing list