[CentOS] Installing skype in CentOS 5

James A. Peltier jpeltier at cs.sfu.ca
Wed Nov 7 21:06:56 UTC 2007

Andrew Allen wrote:
> Having just upgraded my system from CentOS 4.4 to 5.0, I'm a bit
> disappointed that I still can't install skype from the skype repo using
> yum - when I try yum install skype, I end up with:
> libsigc++20-2.0.17-1.el5. 100% |=========================| 217 kB
> 00:13     
> ---> Package libsigc++20.i386 0:2.0.17-1.el5.rf set to be updated
> --> Running transaction check
> --> Processing Dependency: qt4-x11 >= 4.2 for package: skype
> --> Finished Dependency Resolution
> Error: Missing Dependency: qt4-x11 >= 4.2 is needed by package skype
> Any ideas please as to how this can be overcome so that I can install
> and run this very useful utility?
> Andy
I had a hell of a time getting this to work.  I ended up installing the 
older version of skype (

As far as usefulness goes, you may want to look at alternatives such as 
Ekiga, which are free, cross platform and use open standards.   It's far 
less useful when it has had the video guts ripped out of it (which the 
GNU/Linux client does not support video).

Ekiga is in CentOS 5 base.

James A. Peltier
Technical Director, RHCE
SCIRF | GrUVi @ Simon Fraser University - Burnaby Campus
Phone   : 778-782-3610
Fax     : 778-782-3045
Mobile  : 778-840-6434
E-Mail  : jpeltier at cs.sfu.ca
Website : http://gruvi.cs.sfu.ca | http://scirf.cs.sfu.ca
MSN     : subatomic_spam at hotmail.com

More information about the CentOS mailing list