[CentOS] CentOS5 and ipw2200

Christian Volker cvolker at vmware.com
Mon Nov 12 10:02:19 UTC 2007

Hi all!

I tried to use CentOS5 on an IBM Thinkpad R52 which has an Intel PRO/Wireless
2915ABG Mini-PCI Adapter installed.

I downloaded the firmware from the DAG-Repo (afaik 3.0.0) and added a "alias
eth1 ipw2200" to modules.conf. After the module was loaded successfully
(including the firmware) I was able to configure the card. 

For simplicity I didn't use any encryption. My access point as well is not
using any encryption.

I tried to use DHCP, but the card didn't get assigned to any IP address. So I
used the manual configuration which seemed to work fine during startup. But
unfortunately not network connection could be made. So no ICMP ping packets
where reaching the destination. 

Using the iwconfig command I could see my SSID from the access point. Playing
around with some values didn't have any success.

So I tried using FC8- and it worked fine with fixed address settings. As well
as OpenSuSE 10.2.

Anyone an idea what's going wrong here?

Christian Volker

Technical Support Engineer
Parnell House, Barrack Square, Ballincollig, Co. Cork, Ireland


More information about the CentOS mailing list