[CentOS] ntp queries not being answered

Engineer, Gaurav gaurav.engineer at lmco.com
Tue Nov 20 13:05:09 UTC 2007

Hello All,

My name is Gaurav, and I am tasked with configuring a linux box with

I am having a problem that I hope you can help me with.

We have installed CentOS V5 on 1 processor down in the lab.  The rest of
the processors on the network are AIX boxes versions 3.2.5 and 5.2.  I
worked through the entire initial NTP configuration; setup the
/etc/ntp.conf file to point to the server, etc.

Now when I run the ntpdate -d <address of server> on the linux box I get
all the right information.
Also, when I run the same command with the address for another non-linux
box (AIX): ntpdate -d <address of non-linux box> I get all the right
information again.

The problem is that the linux box does not answer queries of the command
to it.

So if I enter the following on the non-linux box:

Ntpdate -d <address of linux box>... all the values for offset, etc. are
all zeroed out.  So the linux box is not passing any information back to
the querying processor, even though the command works the other way
(executed on the linux box querying the non-linux box).   Also, I don't
see the usual "transmit....recieve" pattern for the command.... just the

Are there any reasons that the box can query the server and other boxes
successfully, but not answer queries sent to it?

And in an effort to troubleshoot, I have commented out everything in the
/etc/ntp.conf file except the server address to see if there was
something in that file causing the problems, but that didn't work

Do you have any information on this that could help me?  Anything at all
would be appreciated.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20071120/c0421a57/attachment.html>

More information about the CentOS mailing list