[CentOS] Bugzilla Install problems - need last mile help

Scott Ehrlich scott at MIT.EDU
Fri Nov 23 13:59:43 UTC 2007

I've freshly installed CentOS 5 32-bit on a pc, performed a yum update and yum 
upgrade.   I then did a yum install of mysql.

I finally picked up fresh copies of phpmysql and bugzilla and put both in my 
/var/www/html directory.   mysql is running.  I am able to use mysql -u root to 
get into it, and phpmysql is able to get it, too.

After runs of checksetup.pl to ensure all required pre-requisites were 
installed, I ran it one more time, and get the following:

Creating database bugs...
The 'bugs' database could not be created. The error returned was:

     Access denied for user ''@'localhost' to database 'bugs'

This might have several reasons:

* MySQL is not running.
* MySQL is running, but there is a problem either in the
   server configuration or the database access rights. Read the Bugzilla
   Guide in the doc directory. The section about database configuration
   should help.
* Your password for the 'bugs' user, specified in $db_pass, is
   incorrect, in './localconfig'.
* There is a subtle problem with Perl, DBI, or MySQL. Make
   sure all settings in './localconfig' are correct. If all else fails, set
   '$db_check' to 0.

[root at localhost bugzilla]#

What do I need to do next?   I tried creating an empty database called bugs for 
the script to hook into, but no luck.  I tried creating a user bugs with full 
permission, but no luck.

Thanks for any leads.


More information about the CentOS mailing list