[CentOS] Slightly OT - unable to install hplip 2.7 on CentOS 5 64

Fri Nov 9 19:27:02 UTC 2007
Mark Hull-Richter <mhullrich at gmail.com>

I have already reported this as a bug to the HP folks, but I was hoping
someone here might have a clue about this one.

Just bought an HP Deskjet F2120 and tried to install it on my CentOS
5.064-bit system.  The printer installed fine, but sane does not
recognize the
device, so I tried to install hplip 2.7.10, which is supposed to support it.

Installation failed twice - first time because I did not have net-snmp-devel
installed.  I installed that, then tried again.

Now it fails because it claims I do not have libusb installed:

warning: There are 2 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
error: This installer cannot install this dependency for your distro/OS
and/or version.
error: Installation cannot continue without this dependency. Please manually
install this dependency and re-run this installer.

However, both yum and rpm say this is installed:

$ yum list | grep libusb
libusb.i386                              0.1.12-5.1             installed
libusb.x86_64                            0.1.12-5.1             installed
libusb-devel.i386                        0.1.12-5.1             base
libusb-devel.x86_64                      0.1.12-5.1             base

$ rpm -qa | grep libusb

I tried installing via the tarball, but it failed, claiming I don't have
libjpeg installed (it is, both 32 and 64 bit versions).  Note that the
hp-check output (below) shows both of these to be installed....

Any/all assistance/guideance would be appreciated - I'd hate to have to pack
this up and take it back, but I will if need be.


$ hp-check

HP Linux Imaging and Printing System (ver. 1.6.7)
Dependency/Version Check Utility ver. 2.1

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Basic system info...
--> Linux mhrichter 2.6.18-8.1.15.el5.nx #1 SMP Wed Oct 24 16:35:26 PDT 2007
x86_64 x86_64 x86_64 GNU/Linux

Currently installed version...
--> 1.6.7

Checking Python version...
--> Version 2.4.3 installed.
--> OK

Checking for user interface dependencies...
Checking for SIP...
--> OK
Checking for PyQt...
--> OK
Checking Qt version...
--> Version 3.3.6 installed.
--> OK
Checking SIP version...
--> Version 4.4.5 installed
--> OK
Checking PyQt version...
--> Version 3.16.0 installed.
--> OK

Checking for library dependencies...
Checking for libnetsnmp...
--> OK
Checking for libjpeg...
--> OK
Checking for libusb...
--> OK
Checking for libcrypto...
--> OK
Checking for libpthread...
--> OK

Checking for application dependencies...
Checking ghostscript...
--> Version 8.15.2
Checking gcc...
--> gcc (GCC) 4.1.1 20070105 (Red Hat 4.1.1-52)
--> OK
Checking make...
--> GNU Make 3.81
--> OK
Checking ReportLab (optional)...
warning: Not installed. Fax coverpage support will be disabled.

Checking kernel module...
Checking for ppdev (optional)...
--> OK

Checking for CUPS...
--> scheduler is running
--> OK

Checking existing CUPS queues...
 Printer  Device URI                                            HPLIPInstalled?
 -------  --------------------------------------------------
 HP2120   hp:/usb/Deskjet_F2100_series?serial=CN7863R35K04TK          Yes
 MPP1100  parallel:/dev/lp0                                            No

Note: Any CUPS queues that are not 'HPLIP Installed', must be installed
with the 'hp:' or 'hpfax:' backends to have them work in HPLIP. Refer
to the install instructions on http://hplip.sourceforge.net for more help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20071109/2dc62258/attachment-0004.html>