[CentOS] html/form newbie: trying to upload a little data to a server

Tue Nov 20 22:09:00 UTC 2007
Charles E Campbell Jr <charles.e.campbell at nasa.gov>


I've been trying for several hours to upload a few bits of data (not a 
file) from an html form to a server, and none of my variants have worked 
thus far.   I've done some web searching, too.

Anyway, here's the form:

<form method="POST" action="mmsrequest">
 UserID: <input type="text" NAME="userid">
 Date  : <input type="text" NAME="date" value="mm/dd/yy">
 Time  : <input type="text" NAME="time" value="hh:mm:ss">
 <input type="submit"> <input type="reset">

I've tried mmsrequest as a script and as an executable.  Full path, 
etc.  In and out of cgi-bin.

Variants tried:

  I end up with a copy of the script (well, I told the browser not to 
bother trying to display the executable), instead of having the script run.

 I either end up with a "Not Found" or "Method Not Allowed".  I've 
always insured that permissions were rwxrwxrwx, just to avoid any 
permissions problem, expecting to tighten that up after I got the basic 
thing working.

I don't particularly care if the script or executable gets the 
information from the command line separated by ampersands and whatnot, 
environment variable (QUERY_STRING, or so I understand), or from 
standard input.  However, I do care that the script/program gets run and 
does get the information somehow, on the server side.

Any suggestions?

Thank you,
Chip Campbell