[CentOS] Kickstart install via network, nonexistant disk sda

Mon Nov 26 21:53:42 UTC 2007
ethan at 757.org <ethan at 757.org>

Hello all,

   I have 3 Supermicro 1u servers, each with dual 250gb SATA drives.

   I have a server with CentOS 5 64bit setup for pxebooting and kickstart 

   I have a kickstart install file that doesn't specify the disks 
specifically. It works like a champ, and the operating system installs and 

  I have a kickstart install file that specifies the disk devices (sda, 
sdb) pulled and modified from another similiar system. My goal here is 
configuring software RAID.

  Whenever I try to use the file for software raid, she dies with an error:
"Specified nonexistant disk sda in clearpart command" ... if I removed the
--drives-sda,sdb from the clearpart, it will just fail on the part command 
for RAID.

  Now, I struggled with machine #1 for a long time, then realized that it 
is probably the onboard raid in the BIOS, which isn't a real RAID. Turned 
it off, and it appeared to be the solution. I thought I was well on my 
way. I did the same for machines #2 and #3 which had no installation 
attempts, and they would not work.

  I can take the disks from machine #1, which will run through a reinstall 
fine, and throw them in machine #2 and *it will install*. So it seems to 
be an issue with the partition information on the disk.

  I tried doing a dd if=/dev/zero of=/dev/sda (bs=1024 count=10000) to try 
to overwrite any RAID metadata and partition information and what not.

  During the install, when I have the error that sda is invalid, I can hit 
the vty2 (emergency shell) and easily run fdisk /dev/sda and print the 
partition table. So the device is there, and accessable.

I've tried every incarnation of clearpart commands.

My current kickstart info:

# RAID kickstart
# clearpart --linux --drives=sda,sdb
# clearpart --all --linux --initlabel
clearpart --drives=sda,sdb --all --initlabel
# clearpart --all --initlabel --drives=sda,sdb
part raid.9 --size=100 --ondrive=sda
part raid.10 --size=100 --ondrive=sdb
part raid.13 --size=2000 --ondrive=sdb
part raid.12 --size=2000 --ondrive=sda
part raid.16 --size=100 --grow --ondrive=sdb
part raid.15 --size=100 --grow --ondrive=sda
raid /boot --fstype ext3 --level=RAID1 --device=md0 raid.9 raid.10
raid swap --fstype swap --level=RAID1 --device=md1 raid.12 raid.13
raid / --fstype ext3 --level=RAID1 --device=md2 raid.15 raid.16

Any advice is appreciated!