[CentOS] CentOS5 and ipw2200

Mon Nov 12 12:24:20 UTC 2007
Alain Spineux <aspineux at gmail.com>

On Nov 12, 2007 11:02 AM, Christian Volker <cvolker at vmware.com> wrote:
> Hi all!
> I tried to use CentOS5 on an IBM Thinkpad R52 which has an Intel PRO/Wireless
> 2915ABG Mini-PCI Adapter installed.
> I downloaded the firmware from the DAG-Repo (afaik 3.0.0) and added a "alias
> eth1 ipw2200" to modules.conf. After the module was loaded successfully
> (including the firmware) I was able to configure the card.
> For simplicity I didn't use any encryption. My access point as well is not
> using any encryption.
> I tried to use DHCP, but the card didn't get assigned to any IP address. So I
> used the manual configuration which seemed to work fine during startup. But
> unfortunately not network connection could be made. So no ICMP ping packets
> where reaching the destination.
> Using the iwconfig command I could see my SSID from the access point. Playing
> around with some values didn't have any success.
> So I tried using FC8- and it worked fine with fixed address settings. As well
> as OpenSuSE 10.2.

can you compare the iwconfig output on centos5 and FC8 ?

Your was already installed when you installed centos5 ? And for FC8 ?

Can you try to install a FC8 kernel, if you don't suffer dependency
problem ? (or with a FC7 kernel)

If static IP is working, are you sure your DHCP is working on the
wireless side ?


> Anyone an idea what's going wrong here?
> Christian Volker
> Technical Support Engineer
> --
> Parnell House, Barrack Square, Ballincollig, Co. Cork, Ireland
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Alain Spineux
aspineux gmail com
May the sources be with you