[CentOS] X login screen fails on the first try

Frank Cox theatre at sasktel.net
Mon Oct 1 19:11:04 UTC 2007

I set up a Centos 5 machine a couple of weeks ago and everything was working
perfectly.  It survived a few reboots and whatnot with no problem.

I moved it to another location on Saturday afternoon and, again, it booted up
and worked fine.

It was rebooted this morning and now the graphical login screen doesn't
appear.  Everything appears to load normally but once the text login screen
appears, that's it.  No graphical login screen.

If I log in at the text console and type startx I am told that X is already

If I hit ctrl-alt-f7 at the text login screen I see a completely blank/black
screen.  If I then hit ctrl-alt-esc the graphical login screen comes up and
everything works as it should.

If I switch to runlevel 3 and log into the text console and type startx,
my desktop shows up just as it should.

There are no errors that I can see in /var/log/Xorg.0.log.

Again, this all worked fine up until this morning and nothing changed.  Today I
rebooted it several times and I consistently get the behaviour detailed here.

So, what could be going wrong and preventing the graphical login screen from

MELVILLE THEATRE ~ Melville Sask ~ http://www.melvilletheatre.com

More information about the CentOS mailing list