[CentOS] ot: vlans and vmware

Fabian Arrotin fabian.arrotin at arrfab.net
Thu Oct 4 06:07:23 UTC 2007

On Wed, 2007-10-03 at 11:33 -0400, Gordon McLellan wrote:
> Does anyone have VLAN tagging working from within a guest on
> vmware-server?  I'm running a centos 4.5 guest on a centos 5 host with
> vmware server 1.04 and I've tried creating vlans using both
> the /etc/sysconfig/network-scripts method and just doing it from the
> cli via vconfig.  Either way appears to work, the OS creates the
> vlans, but I think vmware's network adapter must be eating the tags or
> something, since the guest is not able to talk to the real vlan on the
> switch. 
> On the host I setup vmnet3 to be bridged to eth1.  I bring eth1 up on
> the host but don't configure it in anyway.  Vmnet3 is configured as
> eth1 on the guest as well.  If I create vlans on eth1 on the host, it
> is able to talk to corresponding vlans on the switch. 
> I'm wondering if there's some trick to get it work or some
> configuration string needed in the vmx file?  Right now I have the
> vlans setup on the host and then bridged to vmnetX adapters for the
> guests.  But this is kind of messy since I have to take all my virtual
> machines down to change anything. 

I agree ... i've done exactly the same thing : creating the ethx.vlan#
interfaces on the host and it works this way. 
I've not tested the reverse : creating the vlan interfaces in guests :
to be honnest, i didn't want to configure the 802.1q virtual adapters in
each virtual machines guests ... so i did it directly on the Host and
bridged each vmnet network to a specific ethx.vlan# interface.
But i agree that if you need to bridge another vlan , you have to run
vmware-config.pl, which will take all the virtual machines down ...
Unfortunately, i can not test what you're trying to do today, but as
soon as i have acces to the infrastructure, i'll do it and keep you
informed ...
Not really directly related (to 802.1q i mean) but i had strange
behaviors on several nics (old broadcom nics in ibm bladecenter) .. have
you tried a firmware upgrade on your nics ? that did the job for me ..

I've asked on the vmware forum if that was possible to modify vmnet
config in a 'hot way' but it seems not possible.
Btw , i've also asked this on the vmware forum, but their answer is that
such setup is too complex for vmware-server (that was not designed to
work with vlans) and of course they point you to esx (aka virtual
infrastructure ... ) ...
But i was answered also that vmware server 2.0 should be released in a
short time ... and that we can expect some newer things ... i hope vmnet
configuration in real-time ...

Fabian Arrotin <fabian.arrotin at arrfab.net>
Solution ? 
echo '16i[q]sa[ln0=aln100%Pln100/snlbx]sbA0D4D465452snlbxq' | dc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.centos.org/pipermail/centos/attachments/20071004/a29e7019/attachment.sig>

More information about the CentOS mailing list