[CentOS] File retrieval from outside hangs, internally is okay, only Centos5 affected

Bent Terp bent at nagstrup.dk
Sun Oct 7 06:51:44 UTC 2007


I have a really weird problem with some of my servers, namely all the
ones running Centos5

When I try to download a file from the server to a machine outside our
Cisco 6500 router/firewall, the download hangs about half the times
(15 out of 40) when less than half a megabyte into the transfer
(varied from 76 kb to 496 kb).

One server has a portchannel (Cisco speak for ethernet bundle), others
do not, some use e1000, some use broadcom, I've tried httpd and scp
transfers, I've tried from three different clients,

Here's the really annoying part: the problem only occurs when
downloading from outside the firewall, not when transferring files
internally in the serverroom! And the switch is the firewall is a
modular chassis, so the data comes over the same backplane regardless.

And there's 42 files in /proc/net/sys/ipv4 which differ between EL4
and Centos5, so I'm a little lost here

Anybody got some ideas?

with kind regards,

PS Crossposted from Centos Forum, in case sombody on the list, who
doesn't read the forum, can help me

More information about the CentOS mailing list