[CentOS] Hosed my software RAID/LVM setup somehow

Kai Schaetzl maillists at conactive.com
Wed Oct 17 14:54:55 UTC 2007

CentOS 5, original kernel (xen and normal) and everything, Linux RAID 1.

I rebooted one of my machines after doing some changes to RAID/LVM and now 
the two RAID partitions that I made changes to are "gone". I cannot boot 
into the system.
On bootup it tells me that the devices md2 and md3 are busy or mounted and 
drops me to the repair shell. When I run fs check manually it just tells 
me the same. mdadm --misc --detail tells me that md2 and md3 are active 
and fine. I wanted to comment out the md2 and md3 devices in fstab (and 
hoped then be able to boot) but I get a "read-only" warning when writing 
to it although mount tells me that / is mounted rw.

What can I do to boot into the system (the system is on /dev/md1 and seems 
to be fine) or repair it?

The history of the changes is as follows.
Originally I had several software-RAID 1 partitions /boot / /home /home2 
on /dev/md0 etc. At the time of creation I didn't know I could use LVM on 
RAID partitions. Yesterday I activated LVM on md2 and md3 as they didn't 
contain anything valuable and put some data on them. What I did is 
unmount, then remove from RAID, then initialized LVM, then created the 
RAID devices again, then created the Volume Groups and Volumes, added 
mount points etc. All succeeded without errors and was working well 
thereafter. I worked several hours with data and xen virtual machines on 
the LVM partitions. The LVM management was done with the LVM manager in 
Gnome (as I'm not very familiar with LVM), the other stuff was done in a 
I assume something is wrong with the LVM setup or LVM doesn't start at 
all. What/how can I check?



Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com

More information about the CentOS mailing list