[CentOS] C5 i386 DVD boot problems

Scott Ehrlich scott at MIT.EDU
Mon Oct 22 19:13:05 UTC 2007

On Mon, 22 Oct 2007, Phil Schaffner wrote:

> On Mon, 2007-10-22 at 13:13 -0400, Scott Ehrlich wrote:
>> I tried to boot from two different CentOS 5 DVDs, both pass the checksum
>> test, and both give me the same error on a Dell laptop from either GUI or
>> text install modes:
>> invalid compressed format (err=2)
>> VFS: Cannot open root device "<NULL>" or unknown-block(253,0)
>> Please append a correct "root=" boot option
>> Kernel panic...
>> I did some google searching and learned other people have had the same
>> problem, but no resolutions were ever posted.
>> I'm downloading the CD version and will see if that makes any difference.
>> Assuming it won't make a difference, how do I resolve this so I can get
>> CentOS installed on the system?
> 1. Try the images/boot.iso or images/diskboot.img from CD or USB media
> respectively.
> 2. If you have some flavor of Linux installed, copy the isolinux/vmlinuz
> and isolinux/initrd.img to /boot (renamed to *-c5* in GRUB example
> below) and create a GRUB or LILO stanza to boot them.
>        title CentOS5 Installer
>                root (cd)
>                kernel /boot/vmlinuz-c5 ro ramdisk=8192
>                initrd /boot/initrd-c5.img
> 3. pxeboot

Turns out the laptop didn't seem to like part of the DVD(s), so I opted to 
boot from CD, and the install went  fine from there.

Always helpful to have both methods available.



> Phil
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

More information about the CentOS mailing list