[CentOS] Centos5-live kernel panic?

Mon Oct 1 03:07:48 UTC 2007
Ted Miller <tedjeanmiller at sbcglobal.net>

I am fairly sure that I had gotten this to work before, and I know that the 
Centos4-live disk worked OK, but now (maybe since I upgraded BIOS) I get 
this sequence after booting the live cd:

Creating /var in RAM ... Done
Found Centos-live.sqfs but couldn't mount it:
Linking /usr to /centos-live/usr
/linuxrc: 1208: [: not found

Freeing unused kernel memory: 296K freed
Write protecting the kernel read-only data: 684K
Kernel panic - not syncing: No init found
Try passing init= option to kernel

So far I:
1. checked md5 of downloaded .iso
2. burned another copy of CD w/ verify after burn using KD3
3. tried CD in a VMWare machine, and it boots up fine
4. tried failsafe boot option

I am guessing that the problem goes back to the "Found centos-live.spfs but 
couldn't mount it" line, as this mounts OK on the VMWare machine.

In case the hardware layout is confusing it, and I really do need to pass 
an init argument to it, my layout is:

IDE 0 Master: None
       Slave:  CD drive
IDE 1 Master: CD drive
       Slave:  hdd (windows 2000 boot)
IDE 2 (SATA): sda
IDE 3 (SATA): sdb
IDE 4 (SATA): sdc

MB is Gigabyte K8N Ultra 9
nVidia NForce 4 chipset
F9c BIOS version
AMD64 processor
1gb RAM

Glad to supply other info if you tell me what you need and where to find it.

Ted Miller