[CentOS] DocX support in OpenOffice

Thu Oct 18 11:00:30 UTC 2007
first last <prelude_2_murder at yahoo.co.uk>

Has anyone got the docx plugin for OpenOffice 2 running in CentOS?

I have tried using the OpenOffice.org rpms and the ones in CentOS, but
the plugin does not seem to work.

To get it working I extracted the rpm from Novell, then copied the
files to the registry/ folders and the Odfconverter to the program/
folder, but I can't get any ooxml files open at all, it gives me an
error about the file being invalid and having to recover, but all that
the recovery gets is an empty file.

I have tried with the official RPMs versions 2.0 and 2.2 and the CentOS
RPMs for 2.0. I have also tried hardcoding the path to where the files
are, instead of using a relative path, but to no avail.

The same procedure works perfectly with Ubuntu 7.04.

Any suggestions?

(My apologies if the question has already been answered, I could not
find it in my email using the search in Yahoo mail).



Yahoo! Answers - Got a question? Someone out there knows the answer. Try it