[CentOS] Problems suspending/hibernating Dell Latitude D810 with CentOS 5

Fri Oct 5 07:30:12 UTC 2007
ArcosCom Linux User <linux at arcoscom.com>

Tried all these and allways the laptop LCD and external monitor goes OFF
and system hangs without suspend or hibernate.

Tried the pm-suspend with the flags you put under terminal
(konsole/gnome-terminal) and into a text console with the same results.

The same with fglrx uninstalled (and rebooted system). In this case, the
test script say that suspend/resume should work fine, but not.

I'm trying updating hal to last version.

I'm looking for how to say HAL my LAPTOP info as I can see in the web link
you put.

For now, I'm waiting my system finish to upgrade gnome (and more packages)
from alcancelibre.org, that appears to be more recent versions and perhaps
this will help me.

If anybody has more info on how I can debug the suspend/resume process,
please, say me.


El Jue, 4 de Octubre de 2007, 17:16, Patrick escribió:
> On Thu, 2007-10-04 at 13:24 +0200, ArcosCom Linux User wrote:
>> Hi all.
>> I'm having problems trying to suspend/hibernate my Dell Latitude D810
>> Laptop.
>> Basically I have an ATI X600 videographics and SATA harddrive and run
>> httpd and mysqld daemons on it.
>> I use fglrx (ATI propietary drivers) and the open too with no success.
>> I tried with 1 and 2 screens configurations with no success.
>> I tried with CA and/or with battery with no success.
>> I need some help to debug de suspend/hibernate proccess and help to
>> discover at wich point the process is stopped.
>> When I try to suspend/hibernate, the screens are powered off, but the
>> system not go into suspend mode or power off (when hibernating). Then I
>> have to use power button to power off/on the lapton and when I login
>> into
>> gnome, It says me that had a problem with suspend/hibernate process.
>> All help is apretiated!!
>> Regards
> Try the quirk site which can help you analyze the problem and fixing it:
> http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html
> Recommendations based on my experience with an Acer TM6465 laptop:
> 1) do not use "vga=..." when booting the laptop. Remove it at boot or
>    from grub.conf. If you get suspend/resume working you can try to turn
>    it back on and see if it still works
> 2) run the quirk-check.sh script for recommendations. Get it here:
>    http://people.freedesktop.org/~hughsient/quirk/quirk-checker.sh
>    If you use the fglrx driver the script will complain and abort so
>    switch to the open driver before using it
> 3) answer all the question on this webpage and follow the advice. For
>    example if that webpage recommends you try "--quirk-s3-bios" or
>    "--quirk-s3-mode" this means that you boot your laptop (without
>    vga=...) and with the open driver, not the proprietary fglrx driver,
>    login to your graphical environment, open a terminal and as root type
>    in:
>    # pm-suspend --quirk-s3-bios
>    or if it does not work
>    # pm-suspend --quirk-s3-mode
> 4) you can only use the fglrx driver and have working suspend/resume if
>    you disable the DRI functionality in the fglrx driver. Obviously it
>    doesn't make sense to use a proprietary driver if you can't use the
>    DRI part so I recommend you switch to the open one.
>    if you really must use fglrx then disable DRI in /etc/X11/xorg.conf:
>    Section "Device"
> 	Identifier  "Videocard0"
> 	Driver      "fglrx"
> 	Option	    "OpenGLOverlay" "off"
> 	Option	    "VideoOverlay" "on"
> 	Option      "no_dri" "yes"        # <----- turn off DRI
>     EndSection
>     Do realize that without DRI the performance of 3D apps like games
>     will be terrible so you might as well use the open driver.
> 6) if everything fails, download Fthe edora 8 Test 3 Live image, boot it
>    on your laptop and check if suspend/resume works. If it does at least
>    you know you have another option.
> Hope this helps.
> Regards,
> Patrick
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos