[CentOS] CentOSPlus Perl Upgrade

Nick Webb webbn at acm.org
Thu Sep 6 19:33:32 UTC 2007

Hey All,

I'm trying to upgrade to perl 5.8.8 via CentOSPlus, but am having no
luck.  Here is what I have done.

# yum list | grep perl
 . . .
perl.i386                                3:5.8.5-12.1           installed
 . . .

Created /etc/yum.repos.d/CentOS-Base.repo with:

#additional packages that extend functionality of existing packages
name=CentOS-$releasever - Plus
exclude=kernel kernel-devel kernel-smp-* kernel-hugemem* kernel-largesmp*

Then tried:
# sudo yum --enablerepo=centosplus upgrade perl
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Excluding Packages from CentOS-4 - Plus
Could not find update match for perl
No Packages marked for Update/Obsoletion

What am I missing?

Actually, looking at the "yum list" output, it looks like the current
version installed is of the i386 architecture, while this machine is
x86_64?  Is that the problem?  If so is it safe to install the i386
package?  Is there an easy way to do this via yum?

# uname -a
Linux dev 2.6.9-42.0.10.ELsmp #1 SMP Tue Feb 27 09:40:21 EST 2007
x86_64 x86_64 x86_64 GNU/Linux

I'm begining to think the previous admin made some poor decisions on
this server...


More information about the CentOS mailing list