[CentOS] Re: parted - is there a problem

Gregory P. Ennis PoMec at PoMec.Net
Tue Sep 25 22:34:25 UTC 2007

On Tue, 2007-09-25 at 09:12 -0700, Scott Silva wrote:
> on 9/24/2007 3:42 PM Gregory P. Ennis spake the following:
> > Everyone,
> > 
> > I recently added a 300gig Seagate sata drive on a Centos 5.0 and have a
> > couple of questions.
> > 
> > The drive was recognized with the device as /dev/sdc.  The system came
> > with some SCCI drives that are labeled as /dev/sda and /dev/sdb.  I was
> > surprised that the sata drives used sdc.  Are the sata drives considered
> > more like SCCI or IDE drives?  
> > 
> > The real problem occurred when I tried to partition the drive with
> > parted.  I used he command mkpart to form one partition of 300 gigs
> > which created /dev/sdc1, and then after 'quiting' parted used mkfs.ext3
> > to create a file system. Everything went as expected with the ability to
> > mount the file system and copy files into it.  However, /dev/sdc1
> > disappeared when I rebooted.  After the reboot /dev/sdc1 was missing and
> > CentOs obviously could not recognize the partition.  The error is
> > probably related to my lack of experience with parted so I tried it 2
> > other times with the same results.
> > 
> > I finally gave up and used fdisk which  has worked without a problem. 
> > 
> > By way of observation I could not find a 'write to disk' command in
> > parted like what is present in fdisk.  Is there a problem with parted or
> > I am just lacking in knowledge of some of the parted commands.
> > Certainly could not find any write like statements in the man pages or
> > the info pages.
> > 
> > Are there others of you that use parted?  What did I do wrong?
> > 
> > Greg Ennis
> Do you remember what command you used to create the partition?
> Should be something like mkpart primary ext2

after entering parted in interactive mode I gave the command
"mkpart" this was followed other questions :

(parted) mkpart
Partition type?  primary/extended? primary
File system type?  [ext2]?
Start? 0
End? 300G  

When this is done /dev/sdc1 was created; it was mountable; and I could
copy files to it.  However when I rebooted /dev/sdc1 was absent and of
course nothing was mountable.


More information about the CentOS mailing list