[CentOS] network driver corruption? Interface disappeared

Mon Sep 3 14:26:26 UTC 2007
Dave <dmehler26 at woh.rr.com>

    I've got a very unusual network interface issue on centos5. I'm setting 
up a router box, with two network interface cards, the first gets it's 
information from a dhcp server, the second is statically configured. I have 
no idea what happened, but yesterday the internal interface eth1 stopped 
showing up. An ifconfig eth1 showed the interface not found, but an 
ifconfig -a shows a strange __tmp interface. Below is some output:

#cat /proc/modules
iptable_filter 7105 0 - Live 0xc890c000
ip_tables 17029 1 iptable_filter, Live 0xc88e6000
x_tables 17349 1 ip_tables, Live 0xc884b000
dm_mirror 29713 0 - Live 0xc892c000
dm_mod 56665 1 dm_mirror, Live 0xc893e000
parport_pc 29157 1 - Live 0xc8923000
lp 15849 0 - Live 0xc8842000
parport 37513 2 parport_pc,lp, Live 0xc8901000
floppy 57125 0 - Live 0xc8914000
ide_cd 40033 0 - Live 0xc88f6000
cdrom 36705 1 ide_cd, Live 0xc88ec000
serio_raw 10693 0 - Live 0xc8847000
pcspkr 7105 0 - Live 0xc8811000
8139cp 26305 0 - Live 0xc88d8000
8139too 28737 0 - Live 0xc88cf000
mii 9409 2 8139cp,8139too, Live 0xc883e000
tulip 50785 0 - Live 0xc88c1000
i2c_viapro 12117 0 - Live 0xc8816000
i2c_core 23745 1 i2c_viapro, Live 0xc8829000
ext3 123081 2 - Live 0xc8860000
jbd 56553 1 ext3, Live 0xc8851000
ehci_hcd 32845 0 - Live 0xc8834000
ohci_hcd 23261 0 - Live 0xc8822000
uhci_hcd 25421 0 - Live 0xc881a000

#cat /etc/modprobe.conf
alias eth0 8139too
alias eth1 tulip
alias net-pf-10 off

#ifconfig eth1
eth1: error fetching interface information: Device not found

#ifconfig -a
__tmp2065753655 Link encap:Ethernet  HWaddr 00:A0:CC:64:E6:3E
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:12 Base address:0x4f00

#cat /etc/sysconfig/network-scripts-ifcfg-eth1
# Internal Ethernet Device (STATIC)

If i reboot the box that tmp long number changes, that made me think that 
the eth1 file was in the middle of an editing session when a crash occurred, 
i however can not find a tmp file for a crashed editor session. I've tried 
removing the nic and putting it in another box, and it worked. I am open to