[CentOS] Installerror on installation Kaffeine on CentOS 5

Sun Sep 9 09:40:50 UTC 2007
Akemi Yagi <amyagi at gmail.com>

On 9/9/07, Timothy Kesten <centos-lst at gmx.de> wrote:
> Hi Folks,
> I've tried to install kaffeine on CentOS 5 but I get following error
> Transaction Check Error:
>   file /usr/share/mimelnk/application/x-mplayer2.desktop from install of
> kaffeine-0.7.1-1.2.el5.rf conflicts with file from package
> kdelibs-3.5.4-11.el5.centos
> Any hints to solve this problem?
> Delete/rename /usr/share/mimelnk/application/x-mplayer2.desktop ?

Looks like a known bug and a newer version of kaffeine has corrected
the problem.  Deleting the offending file does not help because it is
registered in the rpm database.  Fedora Core 6 has kaffeine 0.8.4
which does not have this problem.  The best method is to get the src
file and rebuild from there.  In this particular case, the Fedora
binary seems to install as is (but still not recommended).  Or send a
request to dag and ask for a newer version of kaffeine.