[CentOS] Installation troubles

Tue Sep 11 15:03:11 UTC 2007
Chuck Campbell <campbell at accelinc.com>

On Sat, Sep 08, 2007 at 01:07:50PM -0700, mark pryor wrote:
> This is what you said in the OP 
> <quote>
> The intent is to install the OS onto the 2-320GB drives on the motherboard controller (preferrably in a raid 1 configuration).  The other disks are for our data requirements.
> </quote>

Yes, but it turned out that my install media was indeed corrupt, even though it
passed media verification.

I got a new iso image for the install dvd from a different location, and
burned a new disc.  I did an install from this w/o the earlier reported hang,
or SQUASHFS errors.

I couldn't figure out how to do the raid1 boot device on the MB controller,
or how to do it via s/w raid in the installer, so I installed onto a single 
disc on the MB controller.  I now have 2 individual disks which show up as 
sda and sdb.  I did custom partitioning in the install and set up a /boot, / 
and swap partitions on sda.  I set up additional swap and other partitions 
on sdb.

During the install, I deselected the sdc and sdd, devices during 
partitioning (these are the raid arrays on the 3ware card).  Each is over
2 TB as they stand, so I was afraid of problems with the mke2fs step, and
thought I'd create filesystems after initial boot.  I believe I need to use
4KB block size (or maybe 8KB) to get 2TB filesystems, and wasn't sure the
installer would do this correctly.

The installer saw the 3ware devices (2 of them) because I loaded a driver
from floppy (linux text dd).  I just didn't use them in the install steps.

I ran the install as described above and put grub on the MBR of sda.

The system now boots, so I ran a yum update, which updated 156 packages.
The kernel was updated too, so I set it up to boot the new xen kernel.

The large arrays on the 3ware card don't seem to be recognized either before
or after the yum update.  The /var/log/messages file shows the 3ware card was
found, but doesn't seem to find any exported devices...

The smartd man page indicates I need to use /dev/twaN in the smartd.conf
file, but these device files don't exist.

I'm stuck and at a loss on how to find these 3ware arrays to put filesystems

> The MB controller is fakeraid and to use it would require the dmraid support in the install.

is this through a driver disk?  I'll have to delve into this another day, I 
need to get this machine online with the big raid arrays useable ASAP.

> Was your MB setup by the reseller with the 2 320 GB drives in Raid1? What shows in the Intel Matrix Raid bios? 

No, I added the disks after the machine arrived w/o any OS installed.  At boot
time I see the six onboard slots, with two 400gb grives recognized.

Following this, the 3ware bios reports the other 8 disks in two arrays.

Lastly the adaptec scsi card bios shows no devices attached (this if for the
tape drives later).

> I have installed Fedora on such a SuperMicro board and we went Raid1 using the onboard device. What's easy to mess up is the boot order menu. If you want to boot from the Raid1 array, you have to bring it in as one of the choices. If you have never setup Linux on a SuperMicro its a little tricky.

I have, but not as raid1.  I still haven't done a raid1, because I just 
installed on a single disk to get down the road.

Unfortunately I can't see my 3ware raid arrays now...  I'm getting a bit 


ACCEL Services, Inc.| Specialists in Gravity, Magnetics |  (713)993-0671 ph.
                    |   and Integrated Interpretation   |  (713)993-0608 fax
 633 1/2 W. 21st St.|            Since 1992             |  (713)306-5794 cell
 Houston, TX, 77008 |          Chuck Campbell           | campbell at accelinc.com
                    |  President & Senior Geoscientist  |

     "Integration means more than having all the maps at the same scale!"