[CentOS] mailq.postfix manpage

Fri Sep 14 08:03:15 UTC 2007
Stefano Biagiotti <stefano.biagiotti at vola.it>

Feizhou <feizhou at graffiti.net> wrote:
>Stefano Biagiotti wrote:
>>On CentOS 4 I can't view the mailq man page. I installed postfix and
>>removed sendmail.
>> # LANG=en_US man mailq
>> fopen: No such file or directory
>> Cannot open man page /usr/share/man/man1/sendmail.1.gz
>> No manual entry for mailq
>> # zcat /usr/share/man/man1/mailq.postfix.1.gz
>> .so man1/sendmail.1
>>Solved replacing with ".so man1/sendmail.postfix.1".
>>Has this little typo to be reported in the CentOS Bug Tracker?
>In /etc/alternatives...where does the symlink point to?
> mta-mailqman -> /usr/share/man/man1/mailq.postfix.1.gz

 # ls -al /usr/share/man/man1/mailq.1.gz
 lrwxrwxrwx 1 root root 30 31 lug 16:30 /usr/share/man/man1/mailq.1.gz -> /etc/alternatives/mta-mailqman
 # ls -al /etc/alternatives/mta-mailqman
 lrwxrwxrwx 1 root root 38 31 lug 16:49 /etc/alternatives/mta-mailqman -> /usr/share/man/man1/mailq.postfix.1.gz

What does "zcat /usr/share/man/man1/mailq.postfix.1.gz" show?
If ".so man1/sendmail.1", this file doesn't exist.

>You probably forgot to run system-switch-mail after you installed 
>postfix and then removed sendmail.
I ran system-switch-mail after I installed postfix and before I
removed sendmail.
Stefano Biagiotti