[CentOS] yum kernel update problem

Tue Sep 18 14:39:36 UTC 2007
Akemi Yagi <amyagi at gmail.com>

On 9/18/07, Chuck Campbell <campbell at accelinc.com> wrote:
> On the subject of kernel updates:
> I had my install kernel (2.6.18-8.el5xen) and 2.6.18-8.1.8.el5xen on the box.
> I was unable to originally boot the update (8.1.8xen) because of the 3ware
> driver issues (I needed to use a driver floppy at install time).
> I jumped through some hoops (which I am struggling to understand) with
> weak-updates to get the 2.6.18-8.1.8 kernel to see my raid devices, which
> worked (technology beyond my ken is indistinguishable from magic :-).
> I had a system which booted either kernel and ran fine, and thought I would
> be able to update kernels with impunity from now on.
> I ran the yum update, which updated the kernel along with other things.
> When it ran, it removed my install kernel (2.6.18-8.el5xen).  I now have
> 2.6.18-8.1.8.el5xen and 2.6.18-8.1.10.el5xen.  The 2.6.18-8.1.8.el5xen
> kernel still works fine, but the 2.6.18-8.1.10.el5xen kernel does NOT see my
> raid devices.
> I have a couple of questions:
> Why did it remove my perfectly functioning install kernel?
> How can I stop it from doing this?
> Do I need to re-install the whole OS to get it back (since I needed a driver
> disk at install time to make it work properly)?
> I must admit this wasn't expected behavior (at least not by me).

Not your fault. Look at /etc/yum/pluginconf.d/installonlyn.conf and
edit the line tokeep,


for example to keep 5 kernels (default is 2).

See also http://bugs.centos.org/view.php?id=2042