[CentOS] Weird NFS problem

Mon Sep 24 11:10:44 UTC 2007
Alain Spineux <aspineux at gmail.com>

Hi Frank.

I'm suspecting your network or your network adapter or the driver you use.
Can you try to transfer big file (>10Mo) between your file server and
your centos ?
Using another protocol like : ftp, sftp, scp, http ?
Can you connect your centos on a different network plug, using a
different cable ?
Can you install an other network adapter ?

On 9/22/07, Frank Cox <theatre at sasktel.net> wrote:
> I have a weird NFS problem here.
> I am trying to set up a machine with Centos 5 on it.  First time I've tried
> Centos, but it looks like it's going to be the real thing for some machines
> that I look after that are intended to be long-term "just works" application
> servers.  I plan to start reading and participating in this mailing list now,
> so Hello to everyone!  My name is Frank Cox and I own and operate the Melville
> Theatre in Melville Saskatchewan, Canada.
> My first attempt to install Centos 5 was from ISO files that I put
> on my fileserver, which is the method that I use to install Fedora.  Boot off a
> boot CD, point it to the appropriate directrory on the fileserver, and let 'er
> rip.
> That didn't work this time.  I got to the point where I told the boot CD where
> to find the ISO files on the fileserver, and the whole thing hung up.  I found
> an error message on one of the consoles that said something to the effect of
> "server fileserver not responding, still trying".  And that's as far as I got.
> I tried this a half-dozen times with the same result.
> I thought maybe it just didn't like my fileserver for some reason, so I put the
> ISO files on another of my computers and set up an NFS share on that computer.
> Same thing again.
> I gave up and put Centos 5 onto CD's, booted from CD number 1 and just swapped
> CD's until I'm done.  I thought that solved everything but now I have something
> even weirder.
> I mounted my fileserver like this:
> mount fileserver:/nas/NASDisk-00002/files /mnt/fileserver
> That's exactly the same way that I mount it on my Fedora machines.
> The fileserver mounts without error, and it appears at first glance to work.  I
> can "cd /mnt/fileserver/where-ever" and use ls to view the files that are in
> the directories.
> However, if I try to read the files on the fileserver, my terminal hangs up.
> All I can do is view the directories on my fileserver.  Doing anything
> that reads any file on the fileserver locks up my terminal.
> Logging in again from another terminal and viewing /var/log/messages tells me
> this:
> nfs: server fileserver not responding, still trying
> This appears to be the same problem that I had when I was installing the
> operating system.  Normally if the installer can't find the NFS share due to a
> typo or whatever, it just tells me "Can't find the images" and that's all there
> is to it.  But the installer hung up at the point where it was supposed to
> start reading the images so I think it could find them but couldn't read them
> either.
> This exact same procedure works fine from my Fedora machines.
> What in the world is going on here?  If I can't get NFS to work on this
> machine I'm going to be up the creek because I use LTSP on it to run several
> terminals.
> I haven't tried web browsing from that machine yet, but the ethernet card is
> obviously working because I did a "yum update" and a few "yum installs" with no
> problem.  It is an Intel motherboard and CPU with integrated everything.
> I strongly suspect that I'm doing something stupid here and can't see the
> obvious.  Can someone give me a steer?
> Thanks in advance for any assistance.
> --
> MELVILLE THEATRE ~ Melville Sask ~ http://www.melvilletheatre.com
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Alain Spineux
aspineux gmail com
May the sources be with you