[CentOS] Not able to run kernel-xen with megasr module :/

Sat Apr 19 00:28:51 UTC 2008
Tomasz Nowak <tnowak-p at netventure.pl>

I've managed to install CentOS 5.1 on S5000PAL
with fakeraid Intel Embedded Raid Technology II
Raid1 (LSI chipset) with some help of kickstart
declaration 'driverdisk --source=http://.../driver.img'

Then I've had some problems with yum update - new kernel
didn't know about megasr.ko. I've solved it with commands:

cd /lib/modules/
cp 2.6.18-53.el5PAE/updates/megasr.ko 2.6.18-53.1.14.el5PAE/updates/
depmod -a 2.6.18-53.1.14.el5PAE
mkinitrd /boot/initrd-2.6.18-53.1.14.el5PAE-new.img 2.6.18-53.1.14.el5PAE

at last I've edited grub.conf add '-new' to initr definition.

I'm not sure why I need to do that twice, but it finally worked.:
# uname -r

Now I need to install Xen, so:
# yum -y install xen kernel-xen

After installation I've tried the same command sequence:
cd /lib/modules/
cp 2.6.18-53.el5PAE/updates/megasr.ko 2.6.18-53.1.14.el5xen/updates/
depmod -a 2.6.18-53.1.14.el5xen
mkinitrd /boot/initrd-2.6.18-53.1.14.el5xen-new.img 2.6.18-53.1.14.el5xen
vi /etc/grub.conf (add -new, etc..)

BUT xen kernel won'ts start. Kernel panic, 'unable to mount root', etc.

Am I missing something?
Is it possible to make it work?