[CentOS] Kickstart network settings problem -SOLVED

Thu Apr 24 09:01:31 UTC 2008
Plant, Dean <dean.plant at roke.co.uk>

Ray Van Dolson wrote:
> On Tue, Apr 22, 2008 at 12:47:39PM +0100, Plant, Dean wrote:
>> I would like one of my kickstart scripts to prompt for disk and
>> networking only. Commenting out the disk and network settings makes
>> the installer prompt for disk settings but not for network settings,
>> they default to DHCP. Any idea's how to fix this?
> I'm assuming you are using CentOS 5 here.  I'm not sure why upstream
> disabled this feature -- it was very useful to be able to use
> kickstart with a DHCP IP address initially, but still be prompted for
> network information during the installer portion later (as it did in
> RHEL4). 
> See:
>   https://bugzilla.redhat.com/show_bug.cgi?id=401531
> In addition, I have an RFE in with Upstream to re-add this feature and
> I believe it's slated for inclusion in 5.2 with the --bootproto=query
> option.
> The attachment there however:
>   https://bugzilla.redhat.com/attachment.cgi?id=291881
> patches Anaconda to not skip the network step during installation.
> I've been using this successfully here to "do what I need" while
> waiting for the official fix.
> You can include this in an updates.img file and have it loaded
> automatically on installs.

Thank you Ray, worked a treat.

If like me you have never had to mess with the stage2.img file to fix
installations issues, below shows what is required.

cd ~
wget http://yourwebserver/centos5-dvd/images/stage2.img
mkdir tmp
mount -t squashfs -o loop stage2.img ./tmp
cd tmp
vi ./usr/lib/anaconda/kickstart.py # comment out
dispatch.skipStep("network") at around line 876 or use Ray's patch.
mkdir ../new-stage2
tar cf - . | ( cd ../new-stage2/ ; tar xf - . )
cd ..
yum -y install squashfs-tools
mksquashfs ./new-stage2/ stage2.img.new

Now replace the stage2.img file on the web server with the
stage2.img.new file, renamed to stage2.img of course.