[CentOS] Kickstart network settings problem

Tue Apr 22 15:18:36 UTC 2008
Plant, Dean <dean.plant at roke.co.uk>

James Pearson wrote:
> Plant, Dean wrote:
>> James Pearson wrote:
>>> Plant, Dean wrote:
>>>> I would like one of my kickstart scripts to prompt for disk and
>>>> networking only. Commenting out the disk and network settings makes
>>>> the installer prompt for disk settings but not for network
>>>> settings, they default to DHCP. Any idea's how to fix this?
>>> I think you need to have the network settings defined - something
>>> like: 
>>> network --bootproto static
>>> If you don't give it an IP address (with the --ip option), then it
>>> will prompt for it. This is what I do for NFS installs - as my
>>> netmask, gateway and nameserver addresses are static, I also give
>>> these on the network line. 
>> Does not work, still defaults to DHCP with no prompt. Also if it
>> makes any difference im using v5.1. 
>> I have tried with the 2 network lines shown below in the kickstart
>> file, with and without interactive variable. Still no network
>> configuration screen. :-(
> Hmmm, works OK for me with CentOS 4.X - however, I used a hacked
> version of anaconda - one of my hacks is to set 'netDev.isDynamic' to
> 0 in loader2/loader.c i.e. make static IP the default ... however, I
> thought this was for non-kickstart installs only ... but may be it
> isn't. 

Looks like it's a CentOS 5 feature/bug as I have just tested every
incarnation of the network line and they all get ignored unless I put in
the complete line as per Marc-Andre's post. This DID work in CentOS 4 as
long as the interactive line was specified.