[CentOS] Quation about CentOS 4 xenU kernel

Kai Schaetzl maillists at conactive.com
Fri Aug 1 16:34:49 UTC 2008

Johnny Hughes wrote on Fri, 01 Aug 2008 09:45:43 -0500:

> maybe that modules.conf file came from a normal machine and not the xen 
> machine.

No, but it's not the problem anyway, I didn't think about the initrd at 
I used the last CentOS 4 image that jailtime.org distributed (CentoS 4.5) 
as base for this VM. Then copied over almost all stuff from the physical 
machine while having an eye on the wiki article
(http://wiki.centos.org/HowTos/Xen/MoveNative2DomU) and making a very few 
The VM is now working well, but I can't upgrade the kernel. I'm stuck with 
2.6.9-67.ELxenU which probably is the kernel from the Jailtime image (and 
uses a custom initrd that came with it I suppose, I don't remember 
creating one back then, but maybe I did). If I attempt to make a new 
initrd it barks about the missing ata_piix module which indeed was not 
installed with that kernel. How can I get this module? Can I just copy it 
over from 2.6.9-67.0.22.EL to the 2.6.9-67.0.15.ELxenU tree and then build 
my new initrd?


Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com

More information about the CentOS mailing list