No IPv6 - Re: [CentOS] vncserver on IPv6

Robert Moskowitz rgm at
Tue Aug 12 17:49:32 UTC 2008

Triggered by your comments below about the log...

Rob Lockhart wrote:
> On Mon, Aug 11, 2008 at 12:01 PM, Robert Moskowitz 
> <rgm at <mailto:rgm at>> wrote:
>         On Fri, Aug 8, 2008 at 3:55 PM, Robert Moskowitz
>         <rgm at <mailto:rgm at>
>         <mailto:rgm at <mailto:rgm at>>> wrote:
>              IPv6 support in VNC Server E4.1.7/P4.1.2
>            VNC Server E4.1.7 & P4.1.2 are fully IPv6-aware, but is shipped
>            with IPv6 support disabled by default, for security
>         reasons. IPv6
>            can be enabled by setting "InTransports=IPv6,IPv4" (the default
>            being IPv4 only), either on the command-line when starting
>            vncserver under Unix
>            Ok.  we have vnc-server-4.1.2-9.el5.i386.rpm, so it SHOULD
>         support
>            IPv6.
>            Don't know how to add a setting to the command-line, as I rund
>            VNCserver via the service command, but I added it to
>            /etc/sysconfig/vncservers:
>            InTransports="IPv6"   (note I also tried without the quotes)
>            and netstat -na|grep 5902
>            shows vncserver only running on IPv4 and I can only connect
>         to it
>            via IPv4.
>            So what am I missing?????
>     Rob Lockhart wrote:
>         In /etc/sysconfig/vncservers I have something like this:
>         VNCSERVERS="1:myusername"
>         VNCSERVERARGS[1]="-geometry 1400x1050 -depth 16 -localhost"
>         (so I can only use localhost, which means I only allow
>         connections over ssh or from the local machine).
>         Yours might be something like this:
>         VNCSERVERS="1:robert"
>         VNCSERVERARGS[1]="-geometry 1400x1050 -depth 16
>         InTransports=IPv6,IPv4"
>     Well first my line has [2].  I changed that to [1] and tried all
>     sorts of variants to the above, including putting a - infront of
>     InTransports (like other options), and replacing the = with a
>     space.  No listening on IPv6.
>     I have foudn the RealVNC support mailing list and sent a question
>     there, hopefully to get answers.  But if anyone has anything to
>     suggest here, please do.
> Robert,
> I recently reinstalled VNC - actually "TightVNC" as it's better than 
> VNC for bandwidth.  If you type "Xvnc -h" you'll see all the 
> parameters supported.  I didn't see any options for IPv6 in my 
> version.  But yours might indeed have more options.
> I noticed that the default /etc/init.d/vncserver script seemed to be 
> ignoring my parameters for VNCSERVERARGS as in the log file, it showed 
> listening for all hosts (not just local hosts).  This was confirmed by 
> connecting directly from another machine to the VNC server port (:1 
> which is port 5901).  I had an older version of the vncserver script, 
> and I overwrote the one from the repository with that one, and it took 
> my parameters.  However, the parameters I can confirm are working 
> are:  "-nolisten tcp -localhost -desktop RobHome -geometry 1280x1024".

Dah, log file...

First I stared at the vncserver script.  I am not a script writer, but I 
figured out what VNCSERVERARGS has the [1] after it.  That is for the 
ARGS for screen :1!  So if I use 2, the I need [2], dah.  So I did that 
and NO listening for port 5902.  I went and read the log and found that 
intransport is NOT a valid option....

So now I either go to a different remote console that does support IPv6, 
or get the Personal version from RealVNC.  Interestingly, vncviewer IS 
trying to connect over IPv6 it is sending TCPv6 SYNs out and getting 

More information about the CentOS mailing list