[CentOS] Missing fonts for tightvnc

Robert Moskowitz rgm at htt-consult.com
Wed Aug 13 15:58:58 UTC 2008

Toby Bluhm wrote:
> Robert Moskowitz wrote:
>> You would think installing via yum would handle dependencies, but 
>> perhaps fonts are not managed like dependencies.....
>> Anyway, I installed tightvnc to test out its IPv6 support.
>> Installed ok (after I erased regular vnc). But when I tried to start 
>> it, I got 5 warnings about:
>> Font directory '/usr/X11R6/lib/X11/fonts/misc' not found - ignoring 
>> (then the same message for Speedo, Type1, 75dpi, and 100dpi).
>> Then a fatel server error about: could not open default fount 'fixed'
>> So I looked in the repos (curtesy of yumex) and did find a few 75dpi 
>> a 100dpi fonts, but there seemed to be a lot of these two. I 
>> installed a ocuple of them and tried again. Got the same errors.
>> So how do I fix this one?
> Perhaps vnc can't talk to the xfs daemon - IPv6 or firewall related? 

Perhaps. What ports does xfs use? Why does it work for vncserver (on 
IPv4 only of course)?

But I stopped both iptables and ip6tables and the same error messages.

And installing OpenOffice did not 'fix' things. Perhaps setting symlinks 
may be needed.

More information about the CentOS mailing list