[CentOS] Load Average ~0.40 when idle

Sat Aug 2 00:28:19 UTC 2008
listmail <listmail at entertech.com>

On Sat, 19 Jul 2008 13:48:55 -0700, I wrote
> I am running CentOS 5 on a dual-dual-core Intel machine, and I am seeing
> a load average of between 0.35 and 0.50 while the machine is idle, i.e.
> no processes appear to be running.
> Both top and uptime report the same thing. Looking at top, I cannot 
> see any processes that are using CPU time except for top and init, 
> and they are not using enough cycles to push up the load average.
> According to top, there are occasional tiny (like 0.5%) bumps in the
> system usage occasionally, and almost no user space usage. Again, not
> enough to account for the load average I am seeing.
> I have tried a couple of kernel updates, and upgraded from CentOS 
> 5.0 to 5.2, none of which make any difference.
> Has anyone else seen this? And can anyone recommend a way to figure out
> what is causing the load average to be this high when the machine is 
> idle?
A follow-up now that this issue is resolved. Thanks to the help of some
kind souls on this list, I was able to determine that the problem was only
manifested when the Ethernet drivers were running. This led me to update
the drivers, which solved the problem.

Details for others who will probably encounter this issue:

1. The problem occurs with the 2.6.18-92.1.6.el5 kernels that come with
CentOS 5.2, and the supplied Intel e1000e Ethernet drivers v0.2.0 that
ship with 5.2.

2. The fix is to update the e1000e drivers, which are available from the
Intel web site. I installed e1000e version Instructions
for installation come with the driver; the package I found was

3. You have to compile the drivers from source. They require the kernel-devel
package to be installed in order to compile, of course. But if you are
running the PAE kernel, you need to install kernel-PAE-devel to compile
against. News to me, the naming convention makes it hard to figure out
which name you need until you browse the available kernel packages. Simply
doing yum install kernel-devel does not get you what you need.

I hope this saves someone else the time I wasted figuring this out. :-)