[CentOS] Growing RAID5 on CentOS 4.6

Fri Aug 22 14:13:49 UTC 2008
Stephen Harris <lists at spuddy.org>

I have 4 disks in a RAID5 array.  I want to add a 5th.  So I
  mdadm --add /dev/md3 /dev/sde1
This worked but, as expected, the disk isn't being used in the raid5 array.

md3 : active raid5 sde1[4] sdd4[3] sdc3[2] sdb2[1] sda1[0]
      2930279808 blocks level 5, 64k chunk, algorithm 2 [4/4] [UUUU]

So then I tried the next step:
  mdadm --grow --raid-devices=5 /dev/md3

But now I have problems...
  mdadm: Cannot set device size/shape for /dev/md3: Invalid argument

Can CentOS 4.6 grow md5 arrays?  Or is the kernel and mdadm version too

( http://www.economysizegeek.com/2006/07/15/migrate-raid1-to-raid5-and-grow/
  hints that I need 2.6.17 and mdadm 2.5.2, but it's hard to know what
  the RHEL/CentOS kernel has in it 'cos version numbers no longer match)

I wonder if I could boot off a Ubuntu CD or something and grow the array
that way.  Would be annoying (many hours of server downtime)...