[CentOS] vncserver on IPv6

Sat Aug 9 04:34:49 UTC 2008
Rob Lockhart <rlockhar at gmail.com>

In /etc/sysconfig/vncservers I have something like this:

VNCSERVERARGS[1]="-geometry 1400x1050 -depth 16 -localhost"

(so I can only use localhost, which means I only allow connections over ssh
or from the local machine).

Yours might be something like this:

VNCSERVERARGS[1]="-geometry 1400x1050 -depth 16 InTransports=IPv6,IPv4"

then obviously as root:
service vncserver restart

Have you tried that?  Does VNC work over IPv4?

On Fri, Aug 8, 2008 at 3:55 PM, Robert Moskowitz <rgm at htt-consult.com>wrote:

> http://www.realvnc.com/products/enterprise/4.1/ipv6.html
>   IPv6 support in VNC Server E4.1.7/P4.1.2
> VNC Server E4.1.7 & P4.1.2 are fully IPv6-aware, but is shipped with IPv6
> support disabled by default, for security reasons. IPv6 can be enabled by
> setting "InTransports=IPv6,IPv4" (the default being IPv4 only), either on
> the command-line when starting vncserver under Unix
> Ok.  we have vnc-server-4.1.2-9.el5.i386.rpm, so it SHOULD support IPv6.
> Don't know how to add a setting to the command-line, as I rund VNCserver
> via the service command, but I added it to /etc/sysconfig/vncservers:
> InTransports="IPv6"   (note I also tried without the quotes)
> and netstat -na|grep 5902
> shows vncserver only running on IPv4 and I can only connect to it via IPv4.
> So what am I missing?????
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20080809/09491487/attachment-0004.html>