[CentOS] Xen and bonding on Centos 5.2

Sun Aug 10 18:18:28 UTC 2008
Francesco Camisa <francesco.camisa at policlinicosanmarco.it>

If you are using kernel 92.1.6 it's because apparently there is a bug. I haven't tried 92.1.10 to check if it has been solved. On 5.2 stock kernel on the other hand I have no problems.

Policlinico San Marco

----- Original Message -----
From: "Dirk H. Schulz" <dirk.schulz at kinzesberg.de>
To: "CentOS mailing list" <centos at centos.org>
Sent: Friday, 8 August, 2008 5:33:09 PM GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
Subject: [CentOS] Xen and bonding on Centos 5.2

Hi folks,

I am stuck with a weird phenomenon.

I have set up two servers as xen servers with bonded interfaces (mode 1). 
The bond interface works fine on both servers as long as xen is not used.

When using xen's network-bridge script (with netdev=bond0), one server 
works fine without problems, and the other starts upping and downing the 
slave interfaces of the bond in a very fast manner (several runs per 
second). Both configurations are identical, the only difference is:
- the working server has tg3 nic drivers
- the dysfunctional server has e100 nic drivers.

Does it really depend on the nic driver if bonding works? And why does it 
not work in xen, but work fine without xen? What can I do to analyse the 

I know I could ask this on the xen list, but I fear that this is a 
redhat/centos specific phenomenon.

Any hint or help is appreciated.

CentOS mailing list
CentOS at centos.org