[CentOS] vncserver on IPv6

Tue Aug 12 12:22:30 UTC 2008
Rob Lockhart <rlockhar at gmail.com>

On Mon, Aug 11, 2008 at 12:01 PM, Robert Moskowitz <rgm at htt-consult.com>wrote:

> On Fri, Aug 8, 2008 at 3:55 PM, Robert Moskowitz <rgm at htt-consult.com<mailto:
>> rgm at htt-consult.com>> wrote:
>>    http://www.realvnc.com/products/enterprise/4.1/ipv6.html
>>      IPv6 support in VNC Server E4.1.7/P4.1.2
>>    VNC Server E4.1.7 & P4.1.2 are fully IPv6-aware, but is shipped
>>    with IPv6 support disabled by default, for security reasons. IPv6
>>    can be enabled by setting "InTransports=IPv6,IPv4" (the default
>>    being IPv4 only), either on the command-line when starting
>>    vncserver under Unix
>>    Ok.  we have vnc-server-4.1.2-9.el5.i386.rpm, so it SHOULD support
>>    IPv6.
>>    Don't know how to add a setting to the command-line, as I rund
>>    VNCserver via the service command, but I added it to
>>    /etc/sysconfig/vncservers:
>>    InTransports="IPv6"   (note I also tried without the quotes)
>>    and netstat -na|grep 5902
>>    shows vncserver only running on IPv4 and I can only connect to it
>>    via IPv4.
>>    So what am I missing?????
> Rob Lockhart wrote:
>  In /etc/sysconfig/vncservers I have something like this:
>> VNCSERVERS="1:myusername"
>> VNCSERVERARGS[1]="-geometry 1400x1050 -depth 16 -localhost"
>> (so I can only use localhost, which means I only allow connections over
>> ssh or from the local machine).
>> Yours might be something like this:
>> VNCSERVERS="1:robert"
>> VNCSERVERARGS[1]="-geometry 1400x1050 -depth 16 InTransports=IPv6,IPv4"
> Well first my line has [2].  I changed that to [1] and tried all sorts of
> variants to the above, including putting a - infront of InTransports (like
> other options), and replacing the = with a space.  No listening on IPv6.
> I have foudn the RealVNC support mailing list and sent a question there,
> hopefully to get answers.  But if anyone has anything to suggest here,
> please do.

I recently reinstalled VNC - actually "TightVNC" as it's better than VNC for
bandwidth.  If you type "Xvnc -h" you'll see all the parameters supported.
I didn't see any options for IPv6 in my version.  But yours might indeed
have more options.

I noticed that the default /etc/init.d/vncserver script seemed to be
ignoring my parameters for VNCSERVERARGS as in the log file, it showed
listening for all hosts (not just local hosts).  This was confirmed by
connecting directly from another machine to the VNC server port (:1 which is
port 5901).  I had an older version of the vncserver script, and I overwrote
the one from the repository with that one, and it took my parameters.
However, the parameters I can confirm are working are:  "-nolisten tcp
-localhost -desktop RobHome -geometry 1280x1024".

First, verify via "Xvnc -h" that the parmeters for IPv6 are supported
(InTransports).  Next, could it be possible the ip6tables is blocking you?
My network doesn't use IPv6 so I don't think I could retrace your steps.
Indeed, you are right in that I had omitted a "-" in my email, but didn't
want to waste list bandwidth in sending out the obvious typo.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20080812/a432d5f7/attachment-0004.html>